<!DOCTYPE html>
<html lang="en" xml:lang="en">
<head>
<title>FFC Frankfurt part ways with coach Ross | VAVEL.com</title>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<meta name="description" content="Australian leaves Frankfurt after a season and a half at the helm" />
<meta name="keywords" content="FFC,Frankfurt,part,ways,with,coach,Ross,Women&#039;s Football" />
<meta name="news_keywords" content="FFC,Frankfurt,part,ways,with,coach,Ross,Women&#039;s Football" />
<meta name="author" content="Sophie Lawson" />
<meta name="robots" content="index, follow" />
<link rel="icon" href="https://www.vavel.com/favicon.ico" type="image/x-icon" />
<meta property="og:title" content="FFC Frankfurt part ways with coach Ross" />
<meta property="og:url" content="https://en.vavel.com/en/football/womens-football/832299-ffc-frankfurt-part-ways-with-coach-ross.html" />
<meta property="og:site_name" content="VAVEL.com" />
<meta property="og:description" content="Australian leaves Frankfurt after a season and a half at the helm" />
<meta name="DC.title" lang="en" content=" FFC Frankfurt part ways with coach Ross" />
<meta name="DC.description" lang="en" content="Australian leaves Frankfurt after a season and a half at the helm" />
<meta name="DC.subject" lang="en" content="FFC,Frankfurt,part,ways,with,coach,Ross,Women&#039;s Football" />
<meta name="DC.date" scheme="W3CDTF" content="2017-09-28" />
<meta name="DC.date.issued" scheme="W3CDTF" content="2017-09-28" />
<meta name="DC.creator" content="Vavel" />
<meta name="DC.publisher" content="Vavel" />
<meta name="DC.language" scheme="RFC1766" content="en" />
<meta name="google-play-app" content="app-id=com.mondosports.vavel" />
<meta property="og:image" content="https://img.vavel.com/526797574-4882226642.jpg" />
<meta property="og:type" content="article" />
<meta property="article:section" content="Women&#039;s Football" />
<meta property="fb:admins" content="510371807" />
<meta property="fb:app_id" content="169320175188" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="lawsosop" />
<script sync="" src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"> </script>
<meta property="fb:pages" content="396228670481847" /><meta http-equiv="content-language" content="en" /><meta name="twitter:site" content="@VAVEL" /><meta property="article:publisher" content="https://www.facebook.com/VAVELcom" />
<meta name="twitter:title" content="FFC Frankfurt part ways with coach Ross" />
<meta name="twitter:description" content="Australian leaves Frankfurt after a season and a half at the helm" />
<meta name="twitter:image" content="https://img.vavel.com/526797574-4882226642.jpg" />
<link rel="canonical" href="https://en.vavel.com/football/womens-football/832299-ffc-frankfurt-part-ways-with-coach-ross.html" />
<link href="https://en.vavel.com/amp/en/football/womens-football/832299-ffc-frankfurt-part-ways-with-coach-ross.html" rel="amphtml" />
<link rel="publisher" href="https://plus.google.com/102771328195442871577" />
<link href="https://www.vavel.com/vavel/css/articles1354.css" rel="stylesheet" type="text/css" />
<link href="https://www.vavel.com/themes/default/css/en/english-menu.css" rel="stylesheet" type="text/css" />
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1, user-scalable=0" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta name="apple-mobile-web-app-status-bar-style" content="black" />

<link rel="apple-touch-icon-precomposed" href="https://img.vavel.com/b/vavel-logo-60.png" />
<link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://img.vavel.com/b/vavel-logo-72.png" />
<link rel="apple-touch-icon-precomposed" sizes="76x76" href="https://img.vavel.com/b/vavel-logo-76.png" />
<link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://img.vavel.com/b/vavel-logo-114.png" />
<link rel="apple-touch-icon-precomposed" sizes="120x120" href="https://img.vavel.com/b/vavel-logo-120.png" />
<link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://img.vavel.com/b/vavel-logo-144.png" />
<link rel="apple-touch-icon-precomposed" sizes="152x152" href="https://img.vavel.com/b/vavel-logo-152.png" />
</head>
<body>
<div id="container_main_page">
<header>
<nav class="greybar2">
<div class="greybar2_960">
<ul>
<li><a href="https://en.vavel.com/" title="VAVEL UK" class="black3" target="_blank"><span class="flag flag-uk fltl mgr5" title="VAVEL United Kingdom"></span><span class="mgr15"><b>VAVEL UK</b></span></a></li>
<li><a href="https://usa.vavel.com/" title="VAVEL USA" class="grey3" target="_blank"><span class="flag flag-usa fltl mgr5" title="VAVEL USA"> </span><span class="mgr15"><b>USA</b></span></a></li>
<li><a href="https://es.vavel.com/" title="VAVEL Spain" class="grey3" target="_blank" rel="nofollow"><span class="flag flag-es fltl mgr5" title="VAVEL Spain"> </span><span class="mgr15"><b>Spain</b></span></a></li>
<li><a href="https://mx.vavel.com/" title="VAVEL M&eacute;xico" class="grey3" target="_blank" rel="nofollow"><span class="flag flag-mx fltl mgr5" title="VAVEL Mexico"> </span><span class="mgr15"><b>MX</b></span></a></li>
<li><a href="https://argentina.vavel.com/" title="VAVEL Argentina" class="grey3" target="_blank" rel="nofollow"><span class="flag flag-ar fltl mgr5" title="VAVEL Argentina"> </span><span class="mgr15"><b>Argentina</b></span></a></li>
<li><a href="https://lat.vavel.com/colombia/" title="VAVEL Colombia" class="grey3" target="_blank" rel="nofollow"><span class="flag flag-co fltl mgr5" title="VAVEL Colombia"> </span><span class="mgr15"><b>Colombia</b></span></a></li>
<li><a href="https://www.vavel.com/br/" title="VAVEL Brazil" class="grey3" target="_blank" rel="nofollow"><span class="flag flag-br fltl mgr5" title="VAVEL Brazil"> </span><span class="mgr15"><b>Brazil</b></span></a></li>
<li><a href="https://pt.vavel.com/" title="VAVEL Portugal" class="grey3" target="_blank" rel="nofollow"><span class="flag flag-pt fltl mgr5" title="VAVEL Portugal"> </span><span class="mgr15"><b>PT</b></span></a></li>
<li><a href="https://italia.vavel.com/" title="VAVEL Italia" class="grey3" target="_blank" rel="nofollow"><span class="flag flag-it fltl mgr5" title="VAVEL Italia"> </span><span class="mgr15"><b>Italia</b></span></a></li>
<li><a href="https://fr.vavel.com/" title="VAVEL France" class="grey3" target="_blank" rel="nofollow"><span class="flag flag-fr fltl mgr5" title="VAVEL France"> </span><span class="mgr15"><b>France</b></span></a></li>
<li><a href="https://de.vavel.com/" title="VAVEL Deutschland" class="grey3" target="_blank" rel="nofollow"><span class="flag flag-de fltl mgr5"> </span><span class="mgr15"><b>Deutschland</b></span></a></li>
<li><a href="https://arabic.vavel.com/" title="VAVEL Arabic" class="grey3" target="_blank" rel="nofollow"><span class="flag flag-arb fltl mgr5" title="VAVEL Arabic"> </span><span><b>Arabic</b></span></a></li>

</ul>
</div>
</nav>
<div id="menuholder_top">
<div class="menu_vavel">
<div class="sb-toggle-left">
<a href="https://en.vavel.com/football/womens-football/" title="Women&#039;s Football">
<img src="https://img.vavel.com/arrow-left50.png" height="53" />
</a>
</div>
<div class="sb-toggle-right">
<a href="https://en.vavel.com/"><img src="https://img.vavel.com/vavel-logo-52.png" alt="VAVEL Logo small" /></a>
</div>
<div class="menu-background">
<div class="logo-vavel-menu"><a href="https://en.vavel.com/"><img src="https://www.vavel.com/themes/default/img/vavel_logo_png.png" width="150" alt="VAVEL logo" title="VAVEL logo" /></a></div>
<div class="logo-world-map"> </div>
<nav class="menu_icons">
<ul id="menuholder">
<li class="menu_1662">

</li>
<li class="menu_315">
<a href="https://en.vavel.com/en/football/" title="Football" class="menu_holder">Football</a>

<ul>
<li>
<a href="https://en.vavel.com/football/premier-league/" title="Premier League">
Premier League
</a>
<ul>
<li>
<a href="https://en.vavel.com/football/premier-league/arsenal/" title="Arsenal FC">
Arsenal FC
</a>
</li>
<li>
<a href="https://en.vavel.com/football/premier-league/chelsea-fc/" title="Chelsea FC">
Chelsea FC
</a>
</li>
<li>
<a href="https://en.vavel.com/football/premier-league/crystal-palace/" title="Crystal Palace">
Crystal Palace
</a>
</li>
<li>
<a href="https://en.vavel.com/football/premier-league/everton/" title="Everton FC">
Everton FC
</a>
</li>
<li>
<a href="https://en.vavel.com/football/premier-league/liverpool-fc/" title="Liverpool FC">
Liverpool FC
</a>
</li>
<li>
<a href="https://en.vavel.com/football/premier-league/manchester-city/" title="Manchester City FC">
Manchester City FC
</a>
</li>
<li>
<a href="https://en.vavel.com/football/premier-league/manchester-united/" title="Manchester United FC">
Manchester United FC
</a>
</li>
<li>
<a href="https://en.vavel.com/football/premier-league/newcastle-united/" title="Newcastle United FC">
Newcastle United FC
</a>
</li>
<li>
<a href="https://en.vavel.com/football/premier-league/southampton/" title="Southampton FC">
Southampton FC
</a>
</li>
<li>
<a href="https://en.vavel.com/football/premier-league/stoke-city/" title="Stoke City FC">
Stoke City FC
</a>
</li>
<li>
<a href="https://en.vavel.com/football/premier-league/swansea-city/" title="Swansea City AFC">
Swansea City AFC
</a>
</li>
 <li>
<a href="https://en.vavel.com/football/premier-league/tottenham-hotspur/" title="Tottenham Hotspur">
Tottenham Hotspur
</a>
</li>
<li>
<a href="https://en.vavel.com/football/premier-league/west-bromwich-albion/" title="West Bromwich Albion FC">
West Bromwich Albion FC
</a>
</li>
<li>
<a href="https://en.vavel.com/football/premier-league/west-ham/" title="West Ham United">
West Ham United
</a>
</li>
<li>
<a href="https://en.vavel.com/football/premier-league/bournemouth/" title="AFC Bournemouth">
AFC Bournemouth
</a>
</li>
<li>
<a href="https://en.vavel.com/football/premier-league/watford-fc/" title="Watford FC">
Watford FC
</a>
</li>
<li>
<a href="https://en.vavel.com/football/premier-league/leicester-city/" title="Leicester City">
Leicester City
</a>
</li>
<li>
<a href="https://en.vavel.com/football/premier-league/burnley/" title="Burnley Football Club">
Burnley Football Club
</a>
</li>
<li>
<a href="https://en.vavel.com/football/premier-league/huddersfield-town/" title="Huddersfield Town Football Club">
Huddersfield Town Football Club
</a>
</li>
<li>
<a href="https://en.vavel.com/football/premier-league/brighton-hove-albion/" title="Brighton &amp; Hove Albion Football Club">
Brighton &amp; Hove Albion Football Club
</a>
</li>
</ul>
</li>
 <li>
<a href="https://en.vavel.com/football/championship/" title="Championship">
Championship
</a>
<ul>
<li>
<a href="https://en.vavel.com/football/championship/aston-villa/" title="Aston Villa FC">
Aston Villa FC
</a>
</li>
<li>
<a href="https://en.vavel.com/football/championship/blackburn-rovers/" title="Blackburn Rovers FC">
Blackburn Rovers FC
</a>
</li>
<li>
<a href="https://en.vavel.com/football/championship/reading-fc/" title="Reading FC">
Reading FC
</a>
</li>
<li>
<a href="https://en.vavel.com/football/championship/queens-park-rangers/" title="Queens Park Rangers FC">
Queens Park Rangers FC
</a>
</li>
<li>
<a href="https://en.vavel.com/football/championship/wigan-athletic/" title="Wigan Athletic FC">
Wigan Athletic FC
</a>
</li>
</ul>
</li>
<li>
<a href="https://en.vavel.com/football/womens-football/" title="Women&#039;s Football">
Women&#039;s Football
</a>
</li>
</ul>
</li>
<li class="menu_302">
<a href="https://en.vavel.com/en/international-football/" title="International Football" class="menu_holder">World</a>

<ul>
<li>
<a href="https://en.vavel.com/international-football/italy-calcio/" title="Italy - Calcio">
Italy - Calcio
</a>
</li>
<li>
<a href="https://en.vavel.com/international-football/spain-la-liga/" title="Spain - La Liga">
Spain - La Liga
</a>
</li>
<li>
<a href="https://en.vavel.com/international-football/germany-bundesliga/" title="Germany - Bundesliga">
Germany - Bundesliga
</a>
</li>
<li>
<a href="https://en.vavel.com/international-football/champions-league/" title="Champions League">
Champions League
</a>
</li>
<li>
<a href="https://en.vavel.com/international-football/europa-league/" title="Europa League">
Europa League
</a>
</li>
</ul>
</li>
<li class="menu_304">

</li>
<li class="menu_303">
<a href="https://en.vavel.com/en/tennis/" title="Tennis" class="menu_holder">Tennis</a>


</li>
<li class="menu_1328">
<a href="https://en.vavel.com/en/cricket/" title="Cricket" class="menu_holder">Cricket</a>

</li>
<li class="menu_305">

</li>
<li class="menu_306">
<a href="https://en.vavel.com/en/motorsports/" title="Motorsports" class="menu_holder" style="width: 100px; background-position: -360px 0px;">Motorsports</a>

<ul>
<li>
<a href="https://en.vavel.com/motorsports/formula-1/" title="Formula 1">
Formula 1
</a>
</li>
<li>
<a href="https://en.vavel.com/motorsports/motogp/" title="MotoGP">
MotoGP
</a>
</li>

<li>
<a href="https://en.vavel.com/motorsports/moto3/" title="Moto3">
Moto3
</a>
</li>
<li>
<a href="https://en.vavel.com/motorsports/moto2/" title="Moto2">
Moto2
</a>
</li>
</ul>
</li>
<li class="menu_1391">

</li>
<li class="menu_1531">

</li>
<li class="menu_1545">

</li>
<li class="menu_1644">

</li>
</ul>
</nav>
</div>
</div>
</div>
<nav class="submenu_vavel">
<div class="submenu_960">
<ul id="submenu_holder">
<li class="submenu_1"><a href="https://en.vavel.com/football/premier-league/arsenal/" title="Arsenal" class="submenu_holder">ARS</a></li>
<li class="submenu_2"><a href="https://en.vavel.com/football/premier-league/bournemouth/" title="AFC Bournemouth" class="submenu_holder">BOU</a></li>
<li class="submenu_3"><a href="https://en.vavel.com/football/premier-league/burnley/" title="Burnley" class="submenu_holder">BUR</a></li>
<li class="submenu_4"><a href="https://en.vavel.com/football/premier-league/chelsea-fc/" title="Chelsea" class="submenu_holder">CHE</a></li>
<li class="submenu_5"><a href="https://en.vavel.com/football/premier-league/crystal-palace/" title="Crystal Palace" class="submenu_holder">CRY</a></li>
<li class="submenu_6"><a href="https://en.vavel.com/football/premier-league/everton/" title="Everton" class="submenu_holder">EVE</a></li>
<li class="submenu_7"><a href="https://en.vavel.com/football/premier-league/hull-city/" title="Hull City" class="submenu_holder">HUL</a></li>
<li class="submenu_8"><a href="https://en.vavel.com/football/premier-league/leicester-city/" title="Leicester City" class="submenu_holder">LEI</a></li>
<li class="submenu_9"><a href="https://en.vavel.com/football/premier-league/liverpool-fc/" title="Liverpool" class="submenu_holder">LIV</a></li>
<li class="submenu_10"><a href="https://en.vavel.com/football/premier-league/manchester-city/" title="Manchester City" class="submenu_holder">MCI</a></li>
<li class="submenu_11"><a href="https://en.vavel.com/football/premier-league/manchester-united/" title="Manchester United" class="submenu_holder">MUN</a></li>
<li class="submenu_12"><a href="https://en.vavel.com/football/premier-league/middlesbrough/" title="Middlesbrough" class="submenu_holder">MID</a></li>
<li class="submenu_13"><a href="https://en.vavel.com/football/premier-league/southampton/" title="Southampton" class="submenu_holder">SOU</a></li>
<li class="submenu_14"><a href="https://en.vavel.com/football/premier-league/stoke-city/" title="Stoke City" class="submenu_holder">STK</a></li>
<li class="submenu_15"><a href="https://en.vavel.com/football/premier-league/sunderland/" title="Sunderland" class="submenu_holder">SUN</a></li>
<li class="submenu_16"><a href="https://en.vavel.com/football/premier-league/swansea-city/" title="Swansea" class="submenu_holder">SWA</a></li>
<li class="submenu_17"><a href="https://en.vavel.com/football/premier-league/tottenham-hotspur/" title="Tottenham" class="submenu_holder">TOT</a></li>
<li class="submenu_18"><a href="https://en.vavel.com/football/premier-league/watford-fc/" title="Watford FC" class="submenu_holder">WAT</a></li>
<li class="submenu_19"><a href="https://en.vavel.com/football/premier-league/west-bromwich-albion/" title="West Bromwich Albion" class="submenu_holder">WBA</a></li>
<li class="submenu_20"><a href="https://en.vavel.com/football/premier-league/west-ham/" title="West Ham United" class="submenu_holder">WHU</a></li>
</ul>
</div>
</nav>
<div class="box-white-cat articles-related">
<div class="submenu_960">
 <div class="fltl ad728">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-4378161002089632" data-ad-slot="2469580480" data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<div class="articles-related-new300 news-top">
<div class="articles-related-img">
<div class="articles-related-cut-img"> <a href="https://en.vavel.com/football/womens-football/832299-ffc-frankfurt-part-ways-with-coach-ross.html"><img src="https://img.vavel.com/thumb_526797574-4882226642.jpg" alt="FFC Frankfurt part ways with coach Ross" title="FFC Frankfurt part ways with coach Ross" width="63" /><br /></a></div>
</div>
<h3 class="articles-related-title"><a href="https://en.vavel.com/football/womens-football/832299-ffc-frankfurt-part-ways-with-coach-ross.html">FFC Frankfurt part ways with coach Ross</a></h3>
</div>
</div>
</div>
</header>
<section id="content_article">
<article id="article" itemscope="" itemtype="http://schema.org/NewsArticle">
<header class="article-header">
<h1 itemprop="name headline">FFC Frankfurt part ways with coach Ross</h1>
<time class="date_article" itemprop="datePublished" datetime="2017-09-28">28-09-2017 </time>
<h3 class="abstract" itemprop="description">Australian leaves Frankfurt after a season and a half at the helm</h3>
</header>
<div class="horizontal-rule"> </div>
<aside class="author_bar">
<div class="author_bar_left fltl" itemscope="" itemprop="author creator" itemtype="http://schema.org/Person">
<meta itemprop="name" content="Sophie Lawson" />
<meta itemprop="url" content="https://en.vavel.com/soppysophs/" />
<div class="author_bar_left1">
<a href="https://en.vavel.com/soppysophs/" title="Sophie Lawson">
<img src="https://img.vavel.com/thumb_10532932-10152233182126008-1014873950537024522-n-8678654846.jpg" alt="Sophie Lawson" height="63" class="image" itemprop="image" />
</a>
</div>
<div class="mgt10 mgb5">
<a href="https://en.vavel.com/soppysophs/" title="Sophie Lawson" class="autor2"><span class="FFF" itemprop="name">Sophie Lawson</span></a>
</div>
<div class="social_data">
<div class="fltl mgr5"><a href="https://twitter.com/lawsosop" target="_blank" rel="nofollow"><img src="https://www.vavel.com/themes/default/img/tw25.png" height="20" /></a></div>
</div>
</div>
<aside class="fltr">
<div class="fltl pdr5 mgb20">
<a target="popup" onclick="window.open('https://twitter.com/intent/tweet?original_referer=https://en.vavel.com/en/football/womens-football/832299-ffc-frankfurt-part-ways-with-coach-ross.html&text=FFC Frankfurt part ways with coach Ross&tw_p=tweetbutton&url=https://en.vavel.com/en/football/womens-football/832299-ffc-frankfurt-part-ways-with-coach-ross.html&via=VAVELcom','name','width=600,height=500')"><span class="social_share social_tw" rel="nofollow">Twitter</span></a>
</div>
<div class="fltl pdr5 mgb20">
<a target="popup" onclick="window.open('https://www.facebook.com/sharer/sharer.php?u=https://en.vavel.com/en/football/womens-football/832299-ffc-frankfurt-part-ways-with-coach-ross.html&https://en.vavel.com/en/football/womens-football/832299-ffc-frankfurt-part-ways-with-coach-ross.html','name','width=600,height=500')" rel="nofollow"><span class="social_share social_fb">Facebook</span></a>
</div>
<div class="fltl mgb20">
<a target="popup" onclick="window.open('https://plus.google.com/share?url=https://en.vavel.com/en/football/womens-football/832299-ffc-frankfurt-part-ways-with-coach-ross.html','name','width=600,height=500')"><span class="social_share social_gplus" rel="nofollow">Google Plus</span></a>
</div>
</aside>
</aside>
<div class="horizontal-rule mgb20"> </div>

<figure class="article-image" itemprop="image" itemscope="" itemtype="http://schema.org/ImageObject">
<img src="https://img.vavel.com/526797574-4882226642.jpg" title="FFC Frankfurt part ways with coach Ross" alt="FFC Frankfurt part ways with coach Ross" itemprop="image url" width="610" class="article-image" />
</figure>
<div class="image_caption_news mgb20">
Credit: Getty/Dennis Grombkowski/Bongarts
</div>

<section class="article-content" itemprop="articleBody"><p style="text-align: justify;">Having taken over from<strong> Colin Bell </strong>at the start of last year, <strong>Matt Ross </strong>has left<a href="https://en.vavel.com/tag/1-ffc-frankfurt"><strong> FFC Frankfurt</strong></a> after a turbulent time in <strong>Hesse</strong>.</p>
<h2 style="text-align: justify;">Troubles mounting</h2>
<p style="text-align: justify;">Frankfurt&rsquo;s most recent loss to <a href="https://en.vavel.com/tag/sc-sand"><strong>SC Sand</strong></a> last weekend might have been the nail in the coffin for the Australian but the grave was long-since dug, a fifth-place finish last season that saw them 15 points off of second a far cry from the team of yesterday. &nbsp;</p>
<p style="text-align: justify;">Having moved to the seven-time <a href="https://en.vavel.com/tag/frauen-bundesliga"><strong>Frauen-Bundesliga </strong></a>champions in 2013, initially as a video analyst, Ross has a hand in the success of the third team as well as the U17s before joining Bell&rsquo;s set-up as the Englishman&rsquo;s assistant. After Bell left for <a href="https://en.vavel.com/tag/avaldsnes"><strong>Avaldsnes </strong></a>part-way through the season, Ross stepped up and took charge on an interim basis before agreeing terms with the club, signing a new deal in September of 2016.</p>
<p style="text-align: justify;">With significant hits to the squad over the last few years with the likes of <strong>C&eacute;lia &Scaron;a&scaron;ić</strong>, <strong>Dzsenifer Marozs&aacute;</strong>n and <strong>Simone Laudehr </strong>all leaving for pastures greener as well as <strong>Mandy Islacker </strong>transferring to<a href="http://www.vavel.com/en/tag/fc-bayern-frauen"><strong> Bayern Munich</strong></a> over the summer, the team has slipped down the pecking order. With nowhere to hide after a disappointing 2016-17 season that saw them well off of the top teams, there was at least hope that Ross was planning for the future and the new season would see the team revitalised and ready to mix it with the best of the league once more. However, an opening day 2-0 win over recently promoted <a href="https://en.vavel.com/tag/1-fc-koln-frauen"><strong>FC K&ouml;ln</strong></a> and a narrow 1-0 over a struggling <a href="https://en.vavel.com/tag/tsg-1899-hoffenheim-frauen"><strong>Hoffenheim </strong></a>already looked to have the team on the skids before their home loss to Sand on Sunday.</p>
<h2 style="text-align: justify;">Rennich to take temporary charge</h2>
<p style="text-align: justify;">Frankfurt&nbsp;manager <strong>Siegfried Dietrich</strong> was keen to point out that the recent loss wasn&rsquo;t the loss to Sand but the &ldquo;<em>stagnation in the development</em>&rdquo; of the team, Dietrich not happy with the direction the side was going in. It was with this in mind that the club and Ross agreed to the termination of his contract which was set to run until the end of the 2017-18 season.</p>
<p style="text-align: justify;">Speaking to the FFC website, Dietrich thanked Ross for all his contributions to the club during his time with them and wished him the best of the future.</p>
<p style="text-align: justify;">With Ross gone, assistant&nbsp;coach&nbsp;<strong>Kai Rennich</strong> has taken over the vacant role for the interim whilst the club considers what to do next.&nbsp;</p>
</section>
<div class="ad-body mgb10"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-4378161002089632" data-ad-slot="2853833682" data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script><br /></div>
<div class="clr">
<aside>

<div id="fb-root"> </div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.8&appId=995052417215290";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>
<div class="fb-comments" data-href="https://en.vavel.com/en/football/womens-football/832299-ffc-frankfurt-part-ways-with-coach-ross.html" data-numposts="5"> </div>

<div class="fltl pdr5 mgb20">
<a target="popup" onclick="window.open('https://twitter.com/intent/tweet?original_referer=https://en.vavel.com/en/football/womens-football/832299-ffc-frankfurt-part-ways-with-coach-ross.html&text=FFC Frankfurt part ways with coach Ross&tw_p=tweetbutton&url=https://en.vavel.com/en/football/womens-football/832299-ffc-frankfurt-part-ways-with-coach-ross.html&via=VAVELcom','name','width=600,height=500')"><span class="social_share social_tw" rel="nofollow">Twitter</span></a>
</div>
<div class="fltl pdr5 mgb20">
<a target="popup" onclick="window.open('https://www.facebook.com/sharer/sharer.php?u=https://en.vavel.com/en/football/womens-football/832299-ffc-frankfurt-part-ways-with-coach-ross.html&https://en.vavel.com/en/football/womens-football/832299-ffc-frankfurt-part-ways-with-coach-ross.html','name','width=600,height=500')" rel="nofollow"><span class="social_share social_fb">Facebook</span></a>
</div>
<div class="fltl mgb20">
<a target="popup" onclick="window.open('https://plus.google.com/share?url=https://en.vavel.com/en/football/womens-football/832299-ffc-frankfurt-part-ways-with-coach-ross.html','name','width=600,height=500')"><span class="social_share social_gplus" rel="nofollow">Google Plus</span></a>
</div>
<div itemprop="publisher" itemscope="" itemtype="https://schema.org/Organization" class="fltr">
<meta itemprop="url" content="http://www.vavel.com" />
<div itemprop="logo" itemscope="" itemtype="https://schema.org/ImageObject">
<img src="https://img.vavel.com/b/vavel-logo-72.png" height="65" />
<meta itemprop="url" content="https://img.vavel.com/b/vavel-logo-72.png" />
<meta itemprop="width" content="65" />
<meta itemprop="height" content="65" />
</div>
<meta itemprop="name" content="VAVEL.com" />
</div>
</aside>
</div>
<footer class="article_tags clr mgt5 pdb15">
<span class="more-news">More news about</span>
<ul>
<li itemprop="keywords"><a href="https://en.vavel.com/tag/frauen-bundesliga" title="News about Frauen-Bundesliga" rel="nofollow">Frauen-Bundesliga</a></li>
<li itemprop="keywords"><a href="https://en.vavel.com/tag/1-ffc-frankfurt" title="News about 1.FFC Frankfurt" rel="nofollow">1.FFC Frankfurt</a></li>
<li itemprop="keywords"><a href="https://en.vavel.com/tag/woso" title="News about WoSo" rel="nofollow">WoSo</a></li>

<li itemprop="keywords"><a href="https://en.vavel.com/tag/matt-ross" title="News about Matt Ross" rel="nofollow">Matt Ross</a></li>
</ul>
<div class="clr"> </div>
</footer>
<ul class="breadcrumb clr mgb20 pdt0" itemscope="" itemtype="http://schema.org/BreadcrumbList">
<li itemprop="itemListElement" itemscope="" itemtype="http://schema.org/ListItem" class="fltl">
<a href="https://en.vavel.com/" itemprop="item" class="antetitulo pd0"><meta itemprop="name" content="VAVEL" /></a>
</li>
<li itemprop="itemListElement" itemscope="" itemtype="http://schema.org/ListItem" class="fltl">
<a href="https://en.vavel.com/" itemprop="item" class="antetitulo pd0"><meta itemprop="name" content="English" /></a>
</li>
<li itemprop="itemListElement" itemscope="" itemtype="http://schema.org/ListItem" class="fltl">
> <a href="https://en.vavel.com/football/" itemprop="item" class="antetitulo pd0">
<span itemprop="name">Football</span>
</a>
</li>
<li itemprop="itemListElement" itemscope="" itemtype="http://schema.org/ListItem" class="fltl">
> <a href="https://en.vavel.com/football/womens-football/" itemprop="item" class="antetitulo pd0">
<span itemprop="name">Women&#039;s Football</span>
</a>
</li>
</ul>
<div class="clr">
</div>

</article>


<aside id="article_column">
<div id="right">
<iframe src="https://www.facebook.com/plugins/likebox.php?href=https://www.facebook.com/vavelcom&amp;width=300&amp;colorscheme=light&amp;show_faces=false&amp;border_color&amp;stream=false&amp;header=true&amp;height=62&appId=169320175188" style="border:none; overflow:hidden; width:100%;height:65px;"> </iframe>
<div id="ad300" class="mgt5 pdb0 mgb5"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-4378161002089632" data-ad-slot="1813578941"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<div class="box-white-cat circle-corners10 mgt5">
<h3 class="ubuntu_text fltl mgl15"><a href="https://en.vavel.com/football/womens-football/" title="Women&#039;s Football" class="black3">Women&#039;s Football</a>
</h3>
</div>
<div class="box-white box-white-most-popular">
<div class="clr pdt10 pdb10 brdr1ddd">
<div class="articles-related-img mgb10">
<div class="articles-related-cut-img"> <a href="https://en.vavel.com/football/womens-football/832226-nadia-nadim-joins-manchester-city.html"><img src="https://img.vavel.com/c320_170_nn-9408424263.jpg" alt="image" width="100%" /><br /></a></div>
</div>

<h3 class="articles-related-title-big mgt5"><a href="https://en.vavel.com/football/womens-football/832226-nadia-nadim-joins-manchester-city.html">Nadia Nadim joins Manchester City</a></h3>
<div class="clr pdb5"> </div>
</div>
<div class="clr pdt10 pdb10 brdr1ddd">
<div class="articles-related-img mgb10">
<div class="articles-related-cut-img"> <a href="https://en.vavel.com/football/womens-football/832179-jack-majgaard-jensen-leaves-fc-rosengard-with-immediate-effect.html"><img src="https://img.vavel.com/c320_170_656997044-8872193554.jpg" alt="image" width="100%" /><br /></a></div>
</div>

<h3 class="articles-related-title-big mgt5"><a href="https://en.vavel.com/football/womens-football/832179-jack-majgaard-jensen-leaves-fc-rosengard-with-immediate-effect.html">Jack Majgaard Jensen leaves FC Rosengård with immediate effect</a></h3>
<div class="clr pdb5"> </div>
</div>
<div class="clr pdt10 pdb10 brdr1ddd">
<div class="articles-related-img mgb10">
<div class="articles-related-cut-img"> <a href="https://en.vavel.com/football/womens-football/831276-henry-ol.html"><img src="https://img.vavel.com/c320_170_841986582-7255074479.jpg" alt="image" width="100%" /><br /></a></div>
</div>

<h3 class="articles-related-title-big mgt5"><a href="https://en.vavel.com/football/womens-football/831276-henry-ol.html">Amandine Henry returns to Olympique Lyonnais</a></h3>
<div class="clr pdb5"> </div>
</div>
<div class="clr pdt10 pdb10 brdr1ddd">

<div class="articles-related-img mgb10">
<div class="articles-related-cut-img"> <a href="https://en.vavel.com/football/womens-football/831240-fawsl2-week-1-round-up-doncaster-lead-the-way.html"><img src="https://img.vavel.com/c320_170_686258168-6905502160.jpg" alt="image" width="100%" /><br /></a></div>
</div>

<h3 class="articles-related-title-big mgt5"><a href="https://en.vavel.com/football/womens-football/831240-fawsl2-week-1-round-up-doncaster-lead-the-way.html">FA WSL2 week 1 round-up: Doncaster lead the way</a></h3>
<div class="clr pdb5"> </div>
</div>
<div class="clr pdt10 pdb10 brdr1ddd">
<div class="articles-related-img mgb10">
<div class="articles-related-cut-img"> <a href="https://en.vavel.com/football/womens-football/831223-damallsvenskan-week-16-review-orebro-pick-up-an-unlikely-point.html"><img src="https://img.vavel.com/c320_170_review-3410008875-6614393801-4898946271-9671096703-3423210456.jpg" alt="image" width="100%" /><br /></a></div>
</div>

<h3 class="articles-related-title-big mgt5"><a href="https://en.vavel.com/football/womens-football/831223-damallsvenskan-week-16-review-orebro-pick-up-an-unlikely-point.html">Damallsvenskan week 16 review: Örebro pick up an unlikely point</a></h3>
<div class="clr pdb5"> </div>
</div>
<div class="clr pdt10 pdb10 brdr1ddd">
<div class="articles-related-img mgb10">
<div class="articles-related-cut-img"> <a href="https://en.vavel.com/football/womens-football/831221-liga-iberdrola-week-3-review-top-three-unchanged.html"><img src="https://img.vavel.com/c320_170_32180462483-d1ae4218fc-b-6274782391.jpg" alt="image" width="100%" /><br /></a></div>
</div>

<h3 class="articles-related-title-big mgt5"><a href="https://en.vavel.com/football/womens-football/831221-liga-iberdrola-week-3-review-top-three-unchanged.html">Liga Iberdrola week 3 review: Top three remain unchanged</a></h3>
<div class="clr pdb5"> </div>
</div>
<div class="clr pdt10 pdb10 brdr1ddd">
<div class="articles-related-img mgb10">
<div class="articles-related-cut-img"> <a href="https://en.vavel.com/football/womens-football/831218-frauen-bundesliga-week-3-review-bremen-and-hoffenheim-grab-first-wins-of-the-season.html"><img src="https://img.vavel.com/c320_170_fblr-1018074401-5254333550-5202022832-481099393-9270678330-9779560971-4585949610-6872748406.jpg" alt="image" width="100%" /><br /></a></div>
</div>

<h3 class="articles-related-title-big mgt5"><a href="https://en.vavel.com/football/womens-football/831218-frauen-bundesliga-week-3-review-bremen-and-hoffenheim-grab-first-wins-of-the-season.html">Frauen-Bundesliga week 3 review: Bremen and Hoffenheim grab first wins of the season</a></h3>
<div class="clr pdb5"> </div>
</div>
<div class="clr pdt10 pdb10 brdr1ddd">
<div class="articles-related-img mgb10">
<div class="articles-related-cut-img"> <a href="https://en.vavel.com/football/womens-football/831171-wsl-1-week-1-round-up-chelsea-thrash-bristol-to-top-the-table-on-opening-day-of-fa-wsl-1.html"><img src="https://img.vavel.com/c320_170_l-l-543788322.jpg" alt="image" width="100%" /><br /></a></div>
</div>

<h3 class="articles-related-title-big mgt5"><a href="https://en.vavel.com/football/womens-football/831171-wsl-1-week-1-round-up-chelsea-thrash-bristol-to-top-the-table-on-opening-day-of-fa-wsl-1.html">WSL 1 week 1 round-up: Chelsea thrash Bristol to top the table on opening day of FA WSL 1</a></h3>
<div class="clr pdb5"> </div>
</div>
<div class="clr pdt10 pdb10 brdr1ddd">
<div class="articles-related-img mgb10">
<div class="articles-related-cut-img"> <a href="https://en.vavel.com/football/womens-football/831105-division-1-feminine-week-3-review-ol-regain-top-spot-after-big-win-over-paris-fc.html"><img src="https://img.vavel.com/c320_170_d1-5870758304-8368245-4949556034-9080506679-5553542766-4212206099-9814857044.jpg" alt="image" width="100%" /><br /></a></div>
</div>

<h3 class="articles-related-title-big mgt5"><a href="https://en.vavel.com/football/womens-football/831105-division-1-feminine-week-3-review-ol-regain-top-spot-after-big-win-over-paris-fc.html">Division 1 Féminine Week 3 Review: OL regain top spot after big win over Paris FC</a></h3>
<div class="clr pdb5"> </div>
</div>
<div class="clr pdt10 pdb10 brdr1ddd">
<div class="articles-related-img mgb10">
<div class="articles-related-cut-img"> <a href="https://en.vavel.com/football/womens-football/831034-millwall-3-1-watford-lionesses-kick-new-season-off-with-a-win.html"><img src="https://img.vavel.com/c320_170_img-0071-9243181846.jpg" alt="image" width="100%" /><br /></a></div>
</div>

<h3 class="articles-related-title-big mgt5"><a href="https://en.vavel.com/football/womens-football/831034-millwall-3-1-watford-lionesses-kick-new-season-off-with-a-win.html">Millwall 3-1 Watford: Lionesses kick new season off with a win</a></h3>
<div class="clr pdb5"> </div>
</div>
<div class="clr pdt10 pdb10 brdr1ddd">
<div class="articles-related-img mgb10">
<div class="articles-related-cut-img"> <a href="https://en.vavel.com/football/womens-football/830644-2017-18-wsl-1-season-preview-yeovil-town.html"><img src="https://img.vavel.com/c320_170_charlie-crowhurst-7867353926.jpg" alt="image" width="100%" /><br /></a></div>
</div>

<h3 class="articles-related-title-big mgt5"><a href="https://en.vavel.com/football/womens-football/830644-2017-18-wsl-1-season-preview-yeovil-town.html">2017-18 WSL 1 season preview: Yeovil Town</a></h3>
<div class="clr pdb5"> </div>
 </div>
<div class="clr pdt10 pdb10 brdr1ddd">
<div class="articles-related-img mgb10">
<div class="articles-related-cut-img"> <a href="https://en.vavel.com/football/womens-football/830636-2017-18-wsl-1-season-preview-reading.html"><img src="https://img.vavel.com/c320_170_andrew-powellliverpool-fc-9559416612.jpg" alt="image" width="100%" /><br /></a></div>
</div>

<h3 class="articles-related-title-big mgt5"><a href="https://en.vavel.com/football/womens-football/830636-2017-18-wsl-1-season-preview-reading.html">2017-18 WSL 1 season preview: Reading</a></h3>
<div class="clr pdb5"> </div>
</div>
</div>
</div>
</aside>
</section>
</div>
<script src="//ajax.googleapis.com/ajax/libs/jquery/1.11.0/jquery.min.js"> </script>
<script type="text/javascript" src="https://www.vavel.com/vavel/js/article-a7.js"> </script>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-9914870-1', 'vavel.com');
  ga('require', 'displayfeatures');
  ga('send', 'pageview');

</script>

<script type="text/javascript">
_atrk_opts = { atrk_acct:"Mo9il1awEti2fn", domain:"vavel.com",dynamic: true};
(function() { var as = document.createElement('script'); as.type = 'text/javascript'; as.async = true; as.src = "https://d31qbv1cthcecs.cloudfront.net/atrk.js"; var s = document.getElementsByTagName('script')[0];s.parentNode.insertBefore(as, s); })();
</script>
<noscript><img src="https://d5nxst8fruw4z.cloudfront.net/atrk.gif?account=Mo9il1awEti2fn" style="display:none" height="1" width="1" alt="" /></noscript>

<script type="text/javascript">
    window.cookieconsent_options = {"message":"This website uses cookies to ensure you get the best experience on our website","dismiss":"Got it!","learnMore":"More info","link":"http://www.vavel.com/tos.html","theme":"dark-top"};
</script>
<script type="text/javascript" src="//cdnjs.cloudflare.com/ajax/libs/cookieconsent2/1.0.9/cookieconsent.min.js"></script>



</body>
</html>
